Airless Paint Sprayer Troubleshooting


15 comments

  • georgeEPC

    Good info! I have a 395 seems to build pressure fine. What I did notice was sometimes towards the end of the pressure build, lets say the pump is set to medium and I just placed the gun down…so not spraying for a minute, the pump moves up and down, slows to reach its pressure, but notice the motor rotates backwards a little. Is that normal?

    Reply
  • superior asphalt

    Good video.

    Reply
  • David Warren

    My sprayer leaves trails at the outer margins of the spray pattern. This excess of paint makes me have to back roll the walls. Any ideas why this is happening?

    Reply
  • JOSEPH LES

    i did all that but no pint come out wy paquing all new

    Reply
  • Great Persia

    i have graco 390 after 10 minutes pressure drops and does-not build up again ,any idea?

    Reply
  • Israel Merlin

    my 695 leak from the top where where the metal ball ba that will be the problem

    Reply
  • fortunato of amontillado

    just had a problem with my 395 … paint started to spray out of joint where lower ball and seat is located … took it apart put it back together … same thing … lower packing worn ??? let me know ..cheers … enjoy the videos

    Reply
  • John C Jordan

    Thank you so much, this video really helped me figure out my problem when no one else could.

    Reply
  • Shamiulla Ulla

    I have rongpeng R470 airless Paint sprayer start sprayer prime to spray and prime pipe leakage what is problem sir

    Reply
  • Snap-On kid

    This video was SO MUCH OF A HELP! Thank You!!

    Reply
  • CHI GOMEZ

    My sprayer seems to have a problem with it getting electrical power to the motor. It's like there's a shortage the fan at the back begins to spin then it stops and can't get power back to it

    Reply
  • Frankie Tarin

    My 3400 pressures up without priming, any ideas?

    Reply
  • Jack Spratt

    SO WHERE CAN I FIND INFO ON THE XT 420? TITAN customer service sucks as they could not find info on my unit….ha.

    Reply
  • Don Powell

    I have a strange problem here. Purchased one used and when using it i would work fine for say 10 min then I'll get a streak (10 seconds) of inconsistent pattern then it just stop sending out paint… If I reverse the metal thing that is on the tip (sorry don't know the name), press the trigger the paint will spray out, I would then turn back the metal til in correct position and this will allow consistent paint pattern until I have to redo again. Reversing the tip is just an easy way… I could remove the tip and place it back inside. It's almost like something blocked it but this shouldn't be since the strainer is there to prevent that. I did thin the paint just a little. I'm using Graco x5.

    Reply
  • Fernando.jose De La Guia

    Seguramente si hablaras en español el idioma más repito más hablado del mundo, llegaría a más gente la información

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *